Jump to content

New Facebook Pages

Ford Mach E

Ford Thunder

  • Custom Search


Sign in to follow this  
bradleyheathhays

Problem w/ intermittent defrost a/c

Recommended Posts

Have a '11 Crown Vic with 290k miles and I've been having a problem with the windows fogging up all the way around. The defrost seems to be working about half the time. On humid rainy days it'll work for say a half hour keeping the windows clear, then the windows will fog hard for 10-15 mins. And then it might decide to start working again, back and forth it goes. When I started it just now the compressor clutch turns when the a/c is turned on, although I haven't had a chance to observe it when the windows are fogging.


A secondary problem it has is that it only blows air through the vents on the front of the dash, straight out into the cabin. The air flows only very weak out the defrost vent at the windshield or the floor. It does this on all settings. Although this might contribute somewhat to the problem, it seems like the a/c does completely cut out as the windows will still fog hard with the a/c set to on and on full fan. When it cuts off the air in the cabin feels immediately humid. One that that helps somewhat is to turn the temp toward cooler and it seems to not fog as much and gives it a chance to maybe clear the fog some.


Any idea what's causing this or what I should do to start testing?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×