Jump to content

Custom Search





2019 Lincoln Aviator Introduced Here !


Welcome to Blue Oval Forums


Sign In  Log in with Facebook

Create Account
Welcome to Blue Oval Forums.  You must first register to create topics and post replies. Registration is a quick and easy process and only takes a minute.  Be apart of Blue Oval Forums by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post images
  • Use the Shout feature and more. . .
Click here to create an account now.
 
Guest Message by DevFuse

Photo
- - - - -

2013 MKS EcoBoost Climate Control + Button issue

2013 mks mks climate control mks + button

  • Please log in to reply
15 replies to this topic

#1 OFFLINE   apun

apun

    New BON Member

  • Blue Oval Member
  • Pip
  • 4 posts
  • Joined 30-June 16
  • Region:Canada Ontario
  • Location:Toronto
  • Current Vehicle:2013 MKS Ecoboost

Posted 30 June 2016 - 11:42 AM

I have a 2013 Lincoln MKS Ecoboost, the climate control system is all touch buttons (Not inside of the LCD screen but below the screen) which are pretty nice but lately I have a very annoying issue with the + (plus) Button of the climate control. I would be driving the car and randomly the climate control starts to increase the Temperature as if I am tapping the + button on the climate control area. Sometimes when I press the - (Minus) button as the car is automatically increasing the temperature the temperature stops and then I can controll the temperature manually - or +, but other times no matter what buttons I press the car keeps increasing the temperature and I have to turn off the whole Heat/Ac to make it stop increasing and then turn it back on, but even that sometimes does not fix the problem, anyone knows why this could be and how I can fix this.

 

These are not push buttons that would stick down and the car thinks I am constantly pressing the + button. Mind you the steering wheel buttons I can use also to control the climate work fine, but when the climate control is acting up even these buttons do not seem to work, is this a computer issue or the touch button it self ? I would really appreciate any help/hints. thanks

 

* I have included a picture of the climate controls below, I am talking about the "RED + Button" on the right of "MY TEMP", for some reason it automatically is pressed or the car thinks I am touching it when in fact i am not.

Attached Files









Lose this advertisement by becoming a member. Click here to create a free account.


#2 OFFLINE   akirby

akirby

    fordmantpw's alter ego

  • Moderator
  • 28,948 posts
  • Joined 18-April 06
  • Region:Decline
  • Location:Canton, GA
  • Current Vehicle:2018 F150 Supercab XLT Magnetic Grey 3.5LEB

Posted 30 June 2016 - 12:06 PM

It sounds like the + touch button is engaging when it's not being pressed.  There might be a software update to reduce the sensitivity.  I don't know if it can be cleaned like a regular button.



2018 F150 Supercab XLT Sport (Magnetic) - 3.5LEB
2016 Lincoln MKX Reserve (Luxe/Cappucino)


#3 OFFLINE   BORG

BORG

    Blue Oval Enthusiast

  • Blue Oval Member
  • PipPipPip
  • 8,149 posts
  • Joined 19-September 99
  • Region:Decline
  • Location:None
  • Current Vehicle:None

Posted 30 June 2016 - 12:40 PM

They are capacitive buttons so it's quite possible something on the surface of the button is triggering it to react to capacitance.  Have you tried clean it with a mild glass cleaner?  



#4 OFFLINE   hermans

hermans

    Blue Oval Member

  • Blue Oval Member
  • PipPip
  • 567 posts
  • Joined 02-November 12
  • Region:Decline
  • Location:PA
  • Current Vehicle:2015 MKX - 2013 MKZ Hybrid

Posted 30 June 2016 - 01:11 PM

I've had this issue - eye glass cleaner works great.


2016 Edge Ti

2015 MKC

2013 MKZ Hybrid


#5 OFFLINE   apun

apun

    New BON Member

  • Blue Oval Member
  • Pip
  • 4 posts
  • Joined 30-June 16
  • Region:Canada Ontario
  • Location:Toronto
  • Current Vehicle:2013 MKS Ecoboost

Posted 05 July 2016 - 12:31 PM

Thanks for the replies, I will try eye glass cleaner and see if it helps, forgot to mention - When the car is automatically increasing the temp (or the button pressing by itself) at that moment Even if i try to press the + Button myself, nothing happens. I will try the cleaning, just to make this clear though it is capacitive touch button so we are just talking about cleaning the button from outside right ? (not sure if i can disassemble the whole assembly to see whats going on inside...lose connection or not...



#6 OFFLINE   akirby

akirby

    fordmantpw's alter ego

  • Moderator
  • 28,948 posts
  • Joined 18-April 06
  • Region:Decline
  • Location:Canton, GA
  • Current Vehicle:2018 F150 Supercab XLT Magnetic Grey 3.5LEB

Posted 05 July 2016 - 01:45 PM

Yes outside.

2018 F150 Supercab XLT Sport (Magnetic) - 3.5LEB
2016 Lincoln MKX Reserve (Luxe/Cappucino)


#7 OFFLINE   plm

plm

    New BON Member

  • Blue Oval Member
  • Pip
  • 1 posts
  • Joined 23-July 16
  • Region:U.S. Southern Atlantic
  • Location:United States
  • Current Vehicle:2013 lincoln mks ecoboost

Posted 23 July 2016 - 12:48 PM

Hi, I have just started having the exact same problem with my 2013 lincoln mks. Did you ever find the solution?

#8 OFFLINE   apun

apun

    New BON Member

  • Blue Oval Member
  • Pip
  • 4 posts
  • Joined 30-June 16
  • Region:Canada Ontario
  • Location:Toronto
  • Current Vehicle:2013 MKS Ecoboost

Posted 26 July 2016 - 06:18 PM

unfortunately the cleaning did not help in my case, I have noticed that the problem arises more when the weather gets very hot. Any other suggestions anyone....



#9 OFFLINE   fordtech1

fordtech1

    Blue Oval Member

  • Blue Oval Member
  • PipPip
  • 1,741 posts
  • Joined 31-December 06
  • Region:Decline
  • Location:NC
  • Current Vehicle:2012 Ford Fusion SEL, 2007 Volvo C70, 2006 Mercury Mariner Hybrid, 2005 Ford Focus

Posted 26 July 2016 - 07:05 PM

Probably needs a new panel. It's call the FCIM. Front controls interface module.

#10 OFFLINE   apun

apun

    New BON Member

  • Blue Oval Member
  • Pip
  • 4 posts
  • Joined 30-June 16
  • Region:Canada Ontario
  • Location:Toronto
  • Current Vehicle:2013 MKS Ecoboost

Posted 02 September 2016 - 09:32 AM

Probably needs a new panel. It's call the FCIM. Front controls interface module.

Yes I ended up getting the panel replaced by Ford, over a $1000 :(



#11 OFFLINE   Caver Dave

Caver Dave

    New BON Member

  • Blue Oval Member
  • Pip
  • 2 posts
  • Joined 02-February 17
  • Region:U.S. Northeast
  • Location:West Virginia
  • Current Vehicle:2013 Lincoln MKS

Posted 02 February 2017 - 11:07 PM

I just bought a 2013 MKS last weekend and it's doing the same thing. Mine is more of a problem with the radio scan that the heat, although the heat has ramped to high on me twice. I have found that I can touch anywhere on the face of the controller and it will cause the radio to go into seek mode. I'm hoping that since my car is still under warranty that it won't cost me anything to fix it. How has your new one held up so far?

#12 OFFLINE   SqueejWV

SqueejWV

    New BON Member

  • Blue Oval Member
  • Pip
  • 1 posts
  • Joined 23-April 18
  • Region:U.S. Northeast
  • Location:WV
  • Current Vehicle:2013 MKS AWD

Posted 23 April 2018 - 07:54 PM

I am having this exact issue on a used MKS I bought.  I am having trouble getting a quote to replace the part.  Is there a part number you can refer me to? Thanks!



#13 OFFLINE   chief253

chief253

    New BON Member

  • Blue Oval Member
  • Pip
  • 2 posts
  • Joined 21-June 18
  • Region:U.S. Northeast
  • Location:Massachusetts
  • Current Vehicle:Lincoln MKS

Posted 21 June 2018 - 10:04 PM

Mine too.  Any fixes?


  • spotdog14 likes this

#14 OFFLINE   Caver Dave

Caver Dave

    New BON Member

  • Blue Oval Member
  • Pip
  • 2 posts
  • Joined 02-February 17
  • Region:U.S. Northeast
  • Location:West Virginia
  • Current Vehicle:2013 Lincoln MKS

Posted 22 June 2018 - 10:01 AM

They replaced the whole panel on mine. Not sure what the cost was as it was under warranty. Word of advice though, if thats the only problem youre having with the mks, count yourself lucky. I just got mine back after the dealer having it for 8 weeks to repair what they thought was the cam phasers only to find out the timing chain and tensioner were shot. Kinda ridiculous since it only has 63k on the clock. Before that they had it for 6 weeks replacing a stuck open injector along with the whole exhaust system since the cats broke apart from the heat of all the fuel burning off in them and stopped both mufflers up. Ill be sending this one down the road very soon and will more than likely not be looking at another Ford product again. Between this one and my truck, Im done......

P.S. Sorry for the rant but I do feel a little better now.

#15 OFFLINE   Johnmcrossley

Johnmcrossley

    New BON Member

  • Blue Oval Member
  • Pip
  • 1 posts
  • Joined 22-June 18
  • Region:Decline
  • Location:Houston TX
  • Current Vehicle:2013 MKS Ecoboost

Posted 22 June 2018 - 04:46 PM

Sorry to bring a post back from the dead but I figured someone might find this useful.

I have a 2013 MKS EcoBoost that I purchased used that recently began increasing the ac settings to heat/high. I tried to clean the captive buttons with glass cleaner to see if that was the issue but narrowed it down to a hardware problem. I called my Lincoln dealer and got a hold of somebody in the service department that told me this is a common issue. He also mentioned cars with no tint will develop this issue faster and that it would be ~$960 USD to replace the FCIM.

This part is easy to swap out. I did it in under an hour. The key, according to the service guy was to find the same part number (Ford loves to make multiple part numbers for the same item from year to year). I found a control panel off of a low mileage salvage car on eBay for $120. Mine came with the whole assembly and the ac vents on the center stack.

Install was simple - just take your time. Remove the small wood insert near the starter button and the trim piece around it. They clip in. Repeat this on the passenger side. Behind the trim peices you will see a 7MM bolt - remove that and carefully pull the control panel out and up. Disconnect the plug and swap in the new part. Reassemble and you're done.

#16 OFFLINE   chief253

chief253

    New BON Member

  • Blue Oval Member
  • Pip
  • 2 posts
  • Joined 21-June 18
  • Region:U.S. Northeast
  • Location:Massachusetts
  • Current Vehicle:Lincoln MKS

Posted 26 June 2018 - 10:18 PM

My MKS is turning into a POS. Every time I turn around it's something else. My 3rd brake light is out. another couple of hundred. 51K miles.  A thousand here and a couple of hundred there not to mention the ac condenser and a shock absorber;  it eventually it all adds up to real money. also normal maintenance items.

 

Now I know why i had been sticking to GM vehicles.

 

Anyone have a part number of the panel?










Custom Search


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service | DMCA ·